[rear-users] rear on SLES11 with elilo

Sören Sievers ssievers at ennit.de
Wed Apr 29 17:39:00 CEST 2015


I ran into trouble using rear on SLES11. My first problem was the old 
binary of genisoimage. I copied a newer Version of the binary with EFI 
support on my machine and set the path in local.conf:

This worked fine for me.

On the next run of rear the following error occoured:

2015-04-29 16:12:22 Including prep/GNU/Linux/30_include_grub_tools.sh
2015-04-29 16:12:22 Including prep/default/31_include_uefi_tools.sh
2015-04-29 16:12:22 Using UEFI Boot Loader for Linux 
2015-04-29 16:12:24 Including rescue/default/85_save_sysfs_uefi_vars.sh
2015-04-29 16:12:41 Using UEFI_BOOTLOADER=/boot/efi/efi/SuSE/elilo.efi
2015-04-29 16:13:08 Wrote ISO image: 
/var/lib/rear/output/rear-4care-web01.iso (116M)
2015-04-29 16:13:08 Including output/default/94_grub_rescue.sh
2015-04-29 16:13:08 $grub_conf is set to: /boot/efi/efi/SuSE/grub.conf 
<=== this is my debug output
2015-04-29 16:13:08 ERROR: GRUB configuration cannot be modified.
=== Stack trace ===
Trace 0: /var/lib/rear/usr/sbin/rear:249 main
Trace 1: /var/lib/rear/usr/share/rear/lib/mkrescue-workflow.sh:41 
Trace 2: /var/lib/rear/usr/share/rear/lib/framework-functions.sh:79 
Trace 3: /var/lib/rear/usr/share/rear/lib/framework-functions.sh:40 Source
Trace 4: 
/var/lib/rear/usr/share/rear/output/default/94_grub_rescue.sh:54 source
Trace 5: /var/lib/rear/usr/share/rear/lib/_input-output-functions.sh:131 
Message: GRUB configuration cannot be modified.

Rear correctly sets $UEFI_BOOTLOADER to /boot/efi/efi/SuSE/elilo.efi but 
later rear dies on the error grub.conf doesnt exit.

Is there any workaround ?



More information about the rear-users mailing list