[rear-users] Shortname vs longname causes "show log" to fail

Gratien D'haese gratien.dhaese at telenet.be
Tue Jul 15 04:59:58 CEST 2014


Hi Jeremy, 

Nice little bug - good that found it - do me a please and make an issue of this (copy/paste will do) as I will probably forget about it (I'm having my holidays and read only occationaly my mail). 

----- Original Message -----

From: "Jeremy Laidman" <jlaidman at rebel-it.com.au> 
To: rear-users at lists.relax-and-recover.org 
Sent: Monday, July 14, 2014 8:45:55 AM 
Subject: [rear-users] Shortname vs longname causes "show log" to fail 

Hi 

Due to an error when trying to recover, I get a menu giving me several options, one of which is to view the log. If I try, it gives me an error. Turns out that it's trying to show me a logfile that has my server's FQDN instead of shortname. 

I think the shortname is what's supposed to be used (conf/default.conf sets HOSTNAME to "$(hostname -s)"). But it seems skel/default/etc/scripts/system-setup has this line: 

(1) less /var/log/rear/rear-`uname -n`.log;; 

I think it should be using $HOSTNAME instead of `uname -n`. 

J 


_______________________________________________ 
rear-users mailing list 
rear-users at lists.relax-and-recover.org 
http://pikachu.3ti.be/mailman/listinfo/rear-users 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://pikachu.3ti.be/pipermail/rear-users/attachments/20140715/ac17c468/attachment.html>


More information about the rear-users mailing list