[Rear-users] Off topic - using dd

fuzzy_4711 fuzzy_4711 at gmx.de
Mon Jan 2 19:37:23 CET 2012


Hi.

Please excuse, but I do have a non-rear related question which I am sure
you are able to answer. Please help, even Christmas is over :-)

Here at home, I am running a SUSE 11.4 box. They are using these
/dev/disk/by-uid/... ids for mounting devices. My system has got 2
partitions there: /dev/sda1 mounted at /boot and /dev/sda2 using luks
encryption with lvm2.

I do have 2 identical hard disks and decided to mirror the system to the
2nd disk using dd to use it as a backup.

Now I tried to boot using my "new" backup disk. The first try showed up
the booting screen, listing the kernel I want to use. After choosing it,
the system shows repeatedly the message "Volume group "system" not
found. Reading all physical Volumes. This may take a while." In the end
it was not able to find this volume group.

Well, I did a "cryptsetup luksopen /dev/sda2 system"; vgchange -a y and
mounted /dev/mapper/system-root which holds my / with a live CD.
Thinking I am on the right track, I changed the mount command in
/etc/fstab to the correct device ID which has been reported by the
system in /dev/disk/... Also there was a cache file under the
mountpoint/etc/lvm/.cache. I deleted this one. I grepped for "_SAMSUNG_"
which is part of the disk uid, over serveral dirs where I assumed the
mapping could be found also, without luck. After that I was happy and
tried to boot again. But: Same error message appeared. To be honest I am
kind of fishing in the fork. Do you have an idea where to look out and
change the mapping? Or do you think it is another prob for example
caused by luks?

Also, what do you think - am I following a wrong concept using dd
instead of rear for this scenario?

Thanks for your help.
-fuz


Have a nice 2012!




More information about the rear-users mailing list