[Rear-users] rear mkbackup on gnetoo fails

upen upendra.gandhi at gmail.com
Wed Jul 6 21:40:16 CEST 2011


Thanks Schlomo. It is always great to receive answers from developers
themselves. Really appreciate it. I'd like to provide test results and
any patches if I can develop any.

> BTW, did you notice this?
>
>> 2011-07-06 10:55:37 Including /etc/rear/local.conf
>> /etc/rear/local.conf: line 10: syntax error near unexpected token `('
>> /etc/rear/local.conf: line 10: `BACKUP_PROG_EXCLUDE = ('/tmp/*'
>> '/nfs/*' '/nfs1/*') '

Ah, didn't notice this at all. Thanks for bringing this up and tips as
might not have noticed it for long time. I copied that like from a
website and found there are spaces at some places, I removed other
spaces but didn't notice the ones you pointed :)
http://translate.google.com/translate?tl=en-us&u=http%3A%2F%2Fo-o-s.de%2F%3Fp%3D1666
. This is what I used as a reference for EXCLUDE configuration.

Anyways. Good to know lilo works on x86 architecture. Mine is x86_64
and hope that it works(or I make it work) when it is time for
recovery.

>BTW, how does Gentoo trigger a lilo reinstall after a kernel update? Maybe you
>can detect this and use it as a trigger for lilo instead of Grub...

Generally when I compile kernel on my system, I do mount /boot, copy
the bzImage to /boot/kernel_date and edit /etc/lilo.conf to change the
kernel name for the default label. Last thing is run 'lilo' command
and it install on boot=/dev/sda and I'm done.

Thanks for the notes on debugging , I will try using those if I run
into any issue before posting it here.

Thanks again.


On Wed, Jul 6, 2011 at 1:40 PM, Schlomo Schapiro <schlomo at schapiro.org> wrote:
> Hi,
>
> nice to have someone try out Gentoo again.
>
> On 06/07/11 18:04, upen wrote:
>> Hello,
>>
>> Not that I am not grateful to the developer for this wonderful tool,
>> but rear (Relax & Recover Version 1.11.0 / 2011-05-24 10:39:25 +0200)
>> failed to run mkbackup on my Gentoo(amd64) box.
>>
>> I wonder if someone can help.
>
> Yes, you or any other Gentoo user here. Sadly nobody has been testing (and
> telling us about it) ReaR on Gentoo for a very very long time. It is also not
> part of (at least my) validation setup (and validating it at a certain date
> holds little promise for the future). For example I am pretty sure that this
> release has never been tested on Gentoo.
>
>> Relax & Recover Version 1.11.0 / 2011-05-24 10:39:25 +0200
>> The preparation phase  OK
>> ERROR: Cannot determine filesystem info on 'rootfs'
>> Your udev implementation (vol_id or blkid) does not recognize it.
>> ABORTING DUE TO AN ERROR, CHECK /tmp/rear-aero_ots.log FOR DETAILS
>> Finished in 1 seconds.
>> Terminated
>
> In general ReaR tries to understand your system from /proc/mounts. The more that
> reflects that hard reality on disk the better chances of success, at least for
> the dr code. With the layout code this is again different, I am happy it worked
> for you although the final test is if the layout code would be able to rebuild
> your system.
>
> BTW, did you notice this?
>
>> 2011-07-06 10:55:37 Including /etc/rear/local.conf
>> /etc/rear/local.conf: line 10: syntax error near unexpected token `('
>> /etc/rear/local.conf: line 10: `BACKUP_PROG_EXCLUDE = ('/tmp/*'
>> '/nfs/*' '/nfs1/*') '
>> 2011-07-06 10:55:37 Skipping /etc/rear/rescue.conf (file not found or empty)
>
> It tells you two things:
>
> 1. the entire local.conf has been skipped due to this syntax error ( no blanks
> surrounding a = allowed in Bash syntax, use VAR=value or VAR=( value value ).
>
> 2. That way you override whatever defaults would be set in BACKUP_PROG_EXCLUDE !
> Use BACKUP_PROG_EXCLUDE=( "${BACKUP_PROG_EXCLUDE[@]}" value value value ) to
> append to the array. See http://tldp.org/LDP/abs/html/arrays.html for more info.
>
> To answer your other mail:
>
> lilo is of course also supported on i386 and on x86_64 systems, though your
> system appears to be i386. elilo is indeed supported only on Itanium because it
> is the Itanium port of lilo.
>
> More important is that you teach ReaR to actually use lilo to install your boot
> loader. There is a general problem that it is near to impossible to tell with
> any degree of accuracy how a system was booted (imagine first installing grub on
> /dev/sda1 and then installing lilo on /dev/sda because you switched to
> boot-from-software-raid. lilo would be used but the grub installation is still
> there and would look fine).
>
> The script that so far deals with boot loader installation on Gentoo is
> usr/share/rear/finalize/Gentoo/i386/20_install_grub.sh and it assumes that grub
> is used. So far SUSE_LINUX is the only platform where we try to guess the
> bootloader (lilo or grub) because SUSE_LINUX puts that info into
> /etc/sysconfig/bootloader. On all other distros we just assume that grub was
> used because it is the default.
>
> In your case you will have to contribute some code to ReaR that makes a similar
> decision for Gentoo or that makes this a user configuration item if it is
> technically impossible to know which bootloader was used.
>
> BTW, how does Gentoo trigger a lilo reinstall after a kernel update? Maybe you
> can detect this and use it as a trigger for lilo instead of Grub...
>
> In any case, please submit patches via the sourceforge patches tracker.
>
> Kind Regards,
> Schlomo
>
> PS: To dig deeper into ReaR you can use the various debug flags like -d and -D
> to see more debugging output. That usually helps to locate the exact place where
> something goes wrong.
>
> ------------------------------------------------------------------------------
> All of the data generated in your IT infrastructure is seriously valuable.
> Why? It contains a definitive record of application performance, security
> threats, fraudulent activity, and more. Splunk takes this data and makes
> sense of it. IT sense. And common sense.
> http://p.sf.net/sfu/splunk-d2d-c2
> _______________________________________________
> Rear-users mailing list
> Rear-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/rear-users
>



-- 
upen,
emerge -uD life (Upgrade Life with dependencies)




More information about the rear-users mailing list