[Rear-users] ReaR with SLES11 and TSM Client 6.2.1

Schlomo Schapiro schlomo at schapiro.org
Mon Sep 13 17:02:05 CEST 2010


Hi,

luckily TSM 6.2.2 won't have this problem. I know for sure that the 5.x
did not suffer from it as I helped in several projects that where using
TSM 5.x

I can try to point you to the right starting points to add your code to
ReaR:

First of all you should check out our trunk from SVN and create a local
working copy. Then cd into usr/share/rear and look at the following:

$ grep TSM conf/default.conf
# BACKUP=TSM stuff
COPY_AS_IS_TSM=( /etc/adsm/TSM.PWD /opt/tivoli/tsm/client )
COPY_AS_IS_EXCLUDE_TSM=( )
PROGS_TSM=(dsmc)
# where to copy the resulting files to and save them with TSM
TSM_RESULT_FILE_PATH=/opt/tivoli/tsm/rear
TSM_DSMC_RESTORE_OPTIONS=( )
TSM_RESTORE_PIT_DATE=
TSM_RESTORE_PIT_TIME=

The *default* configs for TSM are found in conf/default.conf. If you
need to add something that should also go to the rescue media please add
it here. Can it be that they simply changed the default path from
/opt/tivoli/tsm/client? Then you might be done with changing the line to
read like
COPY_AS_IS_TSM=( /etc/adsm/TSM.PWD /opt/t?voli/tsm/client
/opt/ibm/<whatever tsm path here> )
This will still work for older TSM clients and pick up the new location
as well. Put a ? instead of one of the letters in the path to trick the
bash into ignoring this path if it does not exist :-)

Then take a look at the existing TSM scripts:
$ ack-grep -af */TSM
output/TSM/default/95_dsmc_save_result_files.sh
prep/TSM/default/40_prep_tsm.sh
restore/TSM/default/40_restore_with_tsm.sh
verify/TSM/default/39_request_point_in_time_restore_parameters.sh
verify/TSM/default/40_verify_tsm.sh

especially prep/TSM/default/40_prep_tsm.sh should be interesting for
you. If you need to modify ReaR on-the-fly then it should go here or in
another script next to it. For example, you could create a
prep/TSM/default/41_hack_tsm_6.2.1.sh script that simply sets
VERSION_INFO to what you want. Or you could create a
build/TSM/default/80_hack_tsm_6.2.1.sh script that would overwrite the
etc/issue in the rescue media with something shorter. Thus the
VERSION_INFO would stay as it is for the other places where we use it.
It contains some useful information you would miss once you start
rolling out ReaR to more than just 1 server.

I would appreciate it if such hacks would be as version-specific (to
TSM) as possible.

To create directories after the restore we already have
restore/default/90_create_missing_directories.sh. You might want to
create a restore/TSM/default/89_create_extra_dirs_for_TSM.sh script to
create stuff that TSM usually ignores. OTOH I would really recommend to
fix TSM to at least restore the directories (dsm.opt ...) as this would
be the root cause while hacking up ReaR would be only a workaround...

HTH,
Schlomo

PS: Look at the other */TSM/* scripts to get a feeling for our Bash
coding style...
PPS: If you can send us some "rear verify" info that would be greatly
appreciated

Am 13.09.2010 13:16, schrieb Joerg Schum:
>   Hi,
> thirst of all, thanks for this grate soft.
> I have done some tests with ReaR 1.7.25 on SLES11_SP1 64bit Systems with 
> running TSM Client 6.2.1.
> Unfortunately this Client has a problem if  the /etc/issue File is to long.
> see: http://www-01.ibm.com/support/docview.wss?uid=swg1IC67814
> 
> I have done some workaround thats works for me.
> 
> In the rear main script ( usr/sbin/rear ) the variable VERSION_INFO was 
> filled with many useful infos, but unfortunately this was the stuff, you 
> find in the /etc/issue when the recovery system boots.
> So i have created a new variable VERSION_INFO_JS="$(uname -n)  : $(dare 
> -R)" in the main script and changed the variable name in the 
> /usr/share/rear/rescue/default/20_etc_issue.sh from $VERSION_INFO to 
> $VERSION_INFO_JS
> So only the building hostname and the buildtime are in the issue file. 
> Thats prevent the dsmc command to do a segmentation fault.
> 
> For the TSM Client 6.2.1 to work in the Recovery environment, it needs 
> some libs installed IMHO on /opt/ibm.?
> I have only tared it together and copyed it over the running recovery 
> system. To include this libs in the isofile, does not worked for me. I 
> have tried it, but the result was not what i expected.
> 
> Is there anyone who can point me to the right way on how to include the 
> necessary libs for the TSM Client 6.2.1?
> 
> An other question ....  It seems that TSM is not right dealing with the 
> /var/lib/nfs/rpc_pipefs mount-point.
> So it was not created after the System was recovered. Has anyone an 
> Workaround of this or is there an option in rear to start an script  
> after the restore is done to create the missing mountpoints?
> 
> excuse my English ... Joerg
> 
> ------------------------------------------------------------------------------
> Start uncovering the many advantages of virtual appliances
> and start using them to simplify application deployment and
> accelerate your shift to cloud computing
> http://p.sf.net/sfu/novell-sfdev2dev
> _______________________________________________
> Rear-users mailing list
> Rear-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/rear-users




More information about the rear-users mailing list