[Rear-users] SLES9: unpredictable behaviour is back

Schlomo Schapiro schlomo at schapiro.org
Thu Jan 29 15:36:58 CET 2009


Hi Werner,

the co[n]fig hack should work well with the shopt -s nullglob option. I
can imagine that sed will hang if both file locations don't work. Can
you please do an rear -D mkrescue and post the log file?

BTW, we are busy working on new releases, you can expect a new "Schlomo"
release today with lots of cool new things. If you quickly send the the
log I might be able to put a fix for your problem in as well.

What is the problem with ReaR/rbme ? You simply setup both to work with
their respective defaults and use a manual rsync to push the backup data
back to the ReaR rescue system. Or do you mean writing a script that
will assist in the restore from RBME?

Regards,
Schlomo

Werner Flamme wrote:
> Hi,
> 
> today I applied the last updates to my SLES9 boxes, the current rear
> (1.7.6 / 2008-08-14) and was happy. I did a "rear mkrescue" on all three
> boxes and was successful on two of them, the third was hanging. As usual
> :-(, it was sed. And again, as I had reported one year ago, at
> /usr/share/rear/build/default/50_patch_sshd_config.sh (I used rear -d
> mkrescue then).
> 
> On this one box, I had to change the simple code in a bulk on lines:
> 
> ---snip---
> shopt -s nullglob
> if [ -f $ROOTFS_DIR/etc/sshd_config ]; then
>     SSHDCONFIGFILE=$ROOTFS_DIR/etc/sshd_config
> elif [ -f $ROOTFS_DIR/etc/ssh/sshd_config ]; then
>     SSHDCONFIGFILE=$ROOTFS_DIR/etc/ssh/sshd_config
> fi
> if [ -n "$SSHDCONFIGFILE" ]; then
>   sed -i  -e 's/PasswordAuthentication.*/PasswordAuthentication no/ig' \
>  -e 's/ChallengeResponseAuthentication.*/ChallengeResponseAuthentication
> no/ig' \
>         -e 's/UsePAM.*/UsePam no/ig' \
>         -e '1i PrintMotd no' \
>             $SSHDCONFIGFILE
> fi
> ---pins---
> 
> Sorry about the alignment, it's the mail client...
> 
> So the sed command itself is untouched, except that I used a variable
> for the name of the config file. The sed on all boxes tells me "GNU sed
> version 4.0.9", so I don't see a reason for this behaviour. I worked
> around the error, but I do not understand why...
> 
> BTW, I still have not worked out a useable backup integration for my
> ReaR images :-( I will do, and share my scripts then (will be rsync/rbme
> and tar).
> 
> Regards,
> Werner
> 
> ------------------------------------------------------------------------------
> This SF.net email is sponsored by:
> SourcForge Community
> SourceForge wants to tell your story.
> http://p.sf.net/sfu/sf-spreadtheword
> _______________________________________________
> Rear-users mailing list
> Rear-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/rear-users




More information about the rear-users mailing list