[Rear-users] minor .spec file changes, and feedback on CentOS 4.6

Schlomo Schapiro schlomo at schapiro.org
Wed Dec 19 17:05:20 CET 2007


Hi Vincent,

thanks for the time to test it on CentOS 4.6 ! Sadly, this platform is
not on my shortlist for QA so I have to rely on others to run tests on it.

The udev / vol_id issue is really stupid because it changed during udev
evolution from vol_id to udev_volume_id.

ReaR should always fall back to the internal version (with a large
warning) that "worked for me". To disable the warning one has to unset
the variable that it mentions.

I will have to verify your SPEC file on SuSE and try to merge the
changes back. Probably I will have to resort to some if clauses to get
it all together, but thanks a lot for the time to give me a working RHEL
version !

Please understand if this will take a while to include, but the next
release will see your code !

To verify the correct symlinks for CentOS you can run ReaR in simulation
mode with -s to see wether all expected scripts are included. Since
CentOS was the first RHEL platform I "did", all other RHEL variants link
to that, not the other way.

ReaR should fail if the /opt/tivoli/tsm/rear/ directory is missing and
does a backup of itself with TSM so that you have a safety copy of the
ISO image in your backup. That worked for me so far, so please do find
out why it doesn't work for you.

Regards,
Schlomo

Vincent Knecht wrote:
> Hello,
> 
>   I've made minor changes to the RPM spec file, mostly adding required packages,
> and using macros for rm/cp/mkdir commands. I'm looking at having it added to
> the RPMForge repository later ( http://dag.wieers.com/rpm/ ).
>   There's still a little issue/warning about files being packaged twice, though
> (the ones in /etc/ with noreplace).
> 
>   Running it on CentOS 4.6, I had a few issues:
> - the previously discussed issue with udev_volume_id vs. vol_id:
>   I rebuilt and installed the one you provide, and then it works.
>   But I somehow feel it's wrong, and it would be neat to have it solved
>   without needed that vol_id RPM.
>   It looks like you did a fallback bash function for RHAS/ia64, but it looks
>   like it's not used on CentOS 4/i386 (even tried simlinking
>   /usr/share/rear/prep/CentOS to /usr/share/rear/prep/RedHatEnterpriseAS
>   but that didn't seem to change anything...
> - When /sbin and /usr/sbin are not in PATH, resp. ip and vgcfgbackup commands
>   are not found.
> - Using TSM as backup method, the backup of ISO image with dsmc fails if one
>   hasn't created /opt/tivoli/tsm/rear/ manually.
>   Strange thing is that when it's there, the rear.log claims that rear created
>   it (and backup succeeds).
> 
> I still haven't tested the ISO image, and recovery, but I can say rear looks
> like a really cool program to me, and solves my worries about restoring a TSM
> backed-up machine when it cannot boot (not having some DR plugin or something).
> 
> Thanks a lot :-)
> 
> 
> ------------------------------------------------------------------------
> 
> -------------------------------------------------------------------------
> SF.Net email is sponsored by:
> Check out the new SourceForge.net Marketplace.
> It's the best place to buy or sell services
> for just about anything Open Source.
> http://ad.doubleclick.net/clk;164216239;13503038;w?http://sf.net/marketplace
> 
> 
> ------------------------------------------------------------------------
> 
> _______________________________________________
> Rear-users mailing list
> Rear-users at lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/rear-users




More information about the rear-users mailing list